Club-S12 International S12OC United Kingdom ClubS12 France S12Silvia Australia S12.org.ua Eastern Europe S12 of Sweden S12 Japan BBS
Please login or register.

Login with username, password and session length

Author Topic: Ka24de Swap Question  (Read 2754 times)

Offline nissan_s12

  • n00b
  • **
  • Location: Guam
  • Posts: 79
Ka24de Swap Question
« on: 06:01:01 AM / 06-Jul-10 »
yeah guys i have a question

ok heres what im having

so i did my swap, took out the ca18et and put a ka24de from a 98 US model s14 240sx
emissions  removed  

it will start and idle but, when i stomp on the gas it will "CHOKE" and i would freak out.
then if i try to roll the gass slow it will choke at 3000 rpm to 3500 rpm and sometimes it will go to 4000rpm but not all the time. has anyone had this problem??

and another one.! when you guys did your swap, did you guys had to change the fuel pump?? im still running the 84 ca18et fuel pump. would that fix it?? anyways

heres what i tried

-a working maff from a car that drove over to let me try it out
-tps from the same car
-pinching the return line to build pressure

heres what im thinking what it might be

- ECU
- fuel pump
- do we need a MAP (manifold absolute pressure) sensor AKA boost sensor



pls let me know cause i want my car up and get drifting again

Facebook Share    

[div align=\"center\"]club s12[/center]
 

Offline Deezus

  • Deezus Christ.
  • Full Member
  • ***
  • Location: central PA
  • Posts: 817
Ka24de Swap Question
« Reply #1 on: 12:30:01 PM / 06-Jul-10 »
You dont need a new fuel pump. And my car did the same thing, and it was a vaccum leak. There are a bunch of smal vac line on the back of the motor, one was split. very hard to see but if you bumped the back of the motor against the firewall putting it in you prolly split one and popped one off.


Deez why the flip are you so smart sometimes.

OMFG THE TROLL IS OUT!

Deezus is always in maximum trollverdrive mode.

Offline nissan_s12

  • n00b
  • **
  • Location: Guam
  • Posts: 79
Ka24de Swap Question
« Reply #2 on: 09:56:18 PM / 06-Jul-10 »
Quote from: Deezus
You dont need a new fuel pump. And my car did the same thing, and it was a vaccum leak. There are a bunch of smal vac line on the back of the motor, one was split. very hard to see but if you bumped the back of the motor against the firewall putting it in you prolly split one and popped one off.


so are you using a stock pump???


well i would think its a vac problem

but i removed all of that. i dont have any vacuum lines in the back. have any other suggestions??
[div align=\"center\"]club s12[/center]
 

Offline sam31183

  • Dark Lord of The Drift
  • Moderators
  • S12 Guru
  • *****
  • Location: Long Beach Wa.
  • Posts: 8,461
  • Vehicle: 1985 Nissan 200SX
Ka24de Swap Question
« Reply #3 on: 11:59:35 PM / 06-Jul-10 »
i am using stock 20e fuel pump with kade...runs fine!

Dave Coleman for President of Earth!!!!
Build Thread Hatch CA18DET Eventually a Track Whore
Build Thread Notch KA24DE Daily Driver

Quote from: Kustamogen
  haha me modding would be a disaster.....Id get all power hungry and  demand n00dz from everyone. Then make all the canadian s12er's come here  and massage my feet and make me jello pudding.

Actually....mod powers plz?!?!?!  0:)

Tedious?  This coming from a person who uses the word twice in a sentence?  I laughed repeatedly...


Offline nissan_s12

  • n00b
  • **
  • Location: Guam
  • Posts: 79
Ka24de Swap Question
« Reply #4 on: 12:07:59 AM / 07-Jul-10 »
thanks man i like your coupe.

thanks for that now i dont need to change my pump^_^
[div align=\"center\"]club s12[/center]
 

Offline sam31183

  • Dark Lord of The Drift
  • Moderators
  • S12 Guru
  • *****
  • Location: Long Beach Wa.
  • Posts: 8,461
  • Vehicle: 1985 Nissan 200SX
Ka24de Swap Question
« Reply #5 on: 12:24:25 AM / 07-Jul-10 »
the car ran before the swap right?


oh, and thanks for the compliment!
« Last Edit: 12:24:42 AM / 07-Jul-10 by sam31183 »

Dave Coleman for President of Earth!!!!
Build Thread Hatch CA18DET Eventually a Track Whore
Build Thread Notch KA24DE Daily Driver

Quote from: Kustamogen
  haha me modding would be a disaster.....Id get all power hungry and  demand n00dz from everyone. Then make all the canadian s12er's come here  and massage my feet and make me jello pudding.

Actually....mod powers plz?!?!?!  0:)

Tedious?  This coming from a person who uses the word twice in a sentence?  I laughed repeatedly...


Offline nissan_s12

  • n00b
  • **
  • Location: Guam
  • Posts: 79
Ka24de Swap Question
« Reply #6 on: 09:52:31 AM / 10-Jul-10 »
Quote from: sam31183
the car ran before the swap right?
oh, and thanks for the compliment!


yeah i tried a diff ecu same problem

i took out my plugs im running rich backfiring like crazy
[div align=\"center\"]club s12[/center]
 

Offline Kustamogen

  • Sr. Member
  • ****
  • Location: Calgary, Alberta
  • Posts: 2,125
  • Vehicle: 1987 Nissan S12
Ka24de Swap Question
« Reply #7 on: 12:29:05 PM / 10-Jul-10 »
timing ok?

Offline drifterb

Ka24de Swap Question
« Reply #8 on: 12:46:07 PM / 10-Jul-10 »
This may help. my car did this and it was the connecters to my fuel injectors. pull them off and see if they are green. if they are clean em up and put some dielectric grease and put em back on. it may help.

Offline nissan_s12

  • n00b
  • **
  • Location: Guam
  • Posts: 79
Ka24de Swap Question
« Reply #9 on: 09:39:13 PM / 10-Jul-10 »
Quote from: drifterb
This may help. my car did this and it was the connecters to my fuel injectors. pull them off and see if they are green. if they are clean em up and put some dielectric grease and put em back on. it may help.


ok thanks man i'll try that out. cause yea im running rich. do ya think it could be a bad fuel press regulator???  


and yea the timming ok. checked it 3 time an set it different ways
[div align=\"center\"]club s12[/center]
 

Offline hotdoghogie

Ka24de Swap Question
« Reply #10 on: 02:17:34 AM / 11-Jul-10 »
There are three vacuum lines under the intake, make sure you got those plugged. Sounds like a vacuum leak not timing or the issue would be fairly consistant, BUTTTTTT you could also have bad gas. did the car sit for long?

also the there is a line to the intake piping just before the TB.
« Last Edit: 02:19:45 AM / 11-Jul-10 by hotdoghogie »

My car is a $1500 '85 nissan. Not a 2mil BMW race car. Im goin lower.

Offline nissan_s12

  • n00b
  • **
  • Location: Guam
  • Posts: 79
Ka24de Swap Question
« Reply #11 on: 02:25:16 AM / 11-Jul-10 »
Quote from: hotdoghogie
There are three vacuum lines under the intake, make sure you got those plugged. Sounds like a vacuum leak not timing or the issue would be fairly consistant, BUTTTTTT you could also have bad gas. did the car sit for long?

also the there is a line to the intake piping just before the TB.


yeah they are all plugged no sound of vac leak and yeah the car sat long, would that cause unable to rev past 3000rpm??

[div align=\"center\"]club s12[/center]
 

Offline hotdoghogie

Ka24de Swap Question
« Reply #12 on: 02:28:49 AM / 11-Jul-10 »
Quote from: nissan_s12
yeah they are all plugged no sound of vac leak and yeah the car sat long, would that cause unable to rev past 3000rpm??

not really just not run at all or run like poo. Normaly bad gas is cause by contamination such as condesation, leaks, additives going stale, ect...

My car is a $1500 '85 nissan. Not a 2mil BMW race car. Im goin lower.