Club-S12 International S12OC United Kingdom ClubS12 France S12Silvia Australia S12.org.ua Eastern Europe S12 of Sweden S12 Japan BBS
Please login or register.

Login with username, password and session length

Author Topic: ca16det idles and runs bad help! ?  (Read 5081 times)

Offline nismo_200sx

  • Full Member
  • ***
  • Location: Pueblo West, Colorado
  • Posts: 404
    • http://
ca16det idles and runs bad help! ?
« on: 09:59:52 PM / 23-Nov-13 »
So I bought a ca16de and swapped over all of my ca18det parts that were known good. Intake manifold eith butterflies amd 370cc injectors. Ca18det cas, maf, tps, cts, etc the only thing ca16 is the longblock. It idles rough and sounds like a Subaru. I checked the plugs that I just put in brand new ngks and they are black but not saturated. I'm thinking the rings aren't seated since this new engine sat for a while in the garage for about 4 years. But it had 30k on it total when it ran. I poured oil down the cylinders and let them soak overnight. And I will be doing a leakdown and compression test. But what would cause this to run bad? Faulty maf? Bad coolant temp sensor? Low compression? Or rich mixture from ca18 ecu on ca16 engine?

Facebook Share    

1987 Nissan 200sx

Offline IggyEGuana

  • Builder - Driver
  • S12 Guru
  • *****
  • Location: Hawthorne, California, USA
  • Posts: 3,754
Re: ca16det idles and runs bad help! ?
« Reply #1 on: 10:19:03 PM / 23-Nov-13 »
the subaru sound is cuz its on 3 cylinders. check for spark coming off the each coil. when i first got my ca18det running i had the same problem along with others. I checked spark at each coil and found a dead one. replaced with an extra and the subie sound went away and it ran a lot better.
Post Merge
btw you can take the CAS off and just spin it by hand with the key on. you dont have to actually crank the motor. just fyi the injectors will fire too so if you do it too much the cylinders will pool up with fuel. unplug the injector dropping resistor and they wont fire.
« Last Edit: 10:22:50 PM / 23-Nov-13 by IggyEGuana »

Waylon Deno - Silhouette Autosports (check it out on facebook)
Drift Build Thread
Quote from: Arro
you sir are emblazoned with win.

Offline nismo_200sx

  • Full Member
  • ***
  • Location: Pueblo West, Colorado
  • Posts: 404
    • http://
Re: ca16det idles and runs bad help! ?
« Reply #2 on: 12:52:18 AM / 06-Dec-13 »
will the coolant temp sensor affect anything? I've heard in school that some ecu's use the coolant temp to run in open or closed loop. what function does the ca18det obd1 o2 sensor do?
1987 Nissan 200sx

Offline seishuku

  • 1998CC's of fun!
  • S12 Guru
  • *****
  • Location: Beloit, WI, USA
  • Posts: 4,937
  • Vehicle: 1987 Nissan S12
Re: ca16det idles and runs bad help! ?
« Reply #3 on: 04:46:03 PM / 06-Dec-13 »
Coolant temp sensor would affect warmup enrichment, might keep it in warmup causing a constant rich state if it were bad.

O2 sensor is only used for idle/cruise and light load fuel trim, to keep fuel ratios near stoichiometric (14.7:1), it's otherwise ignored...
Matt W.
Daily: 2015 Ecoboost Mustang
Previous Daily: 2011 Camaro V6 (tree fell on it)
Previous previous: 2013 VW Jetta TDI super polluter (got bought back)

Offline nismo_200sx

  • Full Member
  • ***
  • Location: Pueblo West, Colorado
  • Posts: 404
    • http://
Re: ca16det idles and runs bad help! ?
« Reply #4 on: 10:44:29 PM / 08-Dec-13 »
on the coolant temp sensor what could I replace it with? it's like a little brass connector thing.
1987 Nissan 200sx

Offline seishuku

  • 1998CC's of fun!
  • S12 Guru
  • *****
  • Location: Beloit, WI, USA
  • Posts: 4,937
  • Vehicle: 1987 Nissan S12
Re: ca16det idles and runs bad help! ?
« Reply #5 on: 09:12:01 PM / 09-Dec-13 »
I don't know for sure 100%, but I'd wager that one from an 88 Pulsar NX with the CA16DE would be the same... Should be able to get one from most auto parts stores.
Matt W.
Daily: 2015 Ecoboost Mustang
Previous Daily: 2011 Camaro V6 (tree fell on it)
Previous previous: 2013 VW Jetta TDI super polluter (got bought back)

Offline IggyEGuana

  • Builder - Driver
  • S12 Guru
  • *****
  • Location: Hawthorne, California, USA
  • Posts: 3,754
Re: ca16det idles and runs bad help! ?
« Reply #6 on: 12:22:09 AM / 10-Dec-13 »
« Last Edit: 12:24:26 AM / 10-Dec-13 by IggyEGuana »

Waylon Deno - Silhouette Autosports (check it out on facebook)
Drift Build Thread
Quote from: Arro
you sir are emblazoned with win.

Offline nismo_200sx

  • Full Member
  • ***
  • Location: Pueblo West, Colorado
  • Posts: 404
    • http://
Re: ca16det idles and runs bad help! ?
« Reply #7 on: 10:59:34 PM / 12-Dec-13 »
ya I have a ca18det ecu
1987 Nissan 200sx