Club-S12 International S12OC United Kingdom ClubS12 France S12Silvia Australia S12.org.ua Eastern Europe S12 of Sweden S12 Japan BBS
Please login or register.

Login with username, password and session length

Author Topic: Handling issues need help (Trouble shoot with me) :P  (Read 1620 times)

Offline 87notch


Here is my post from earlier and i probably should keep posting on it but this seems more relevant to the topic.
http://club-s12.org/retro4/index.php?topic=37629.0

Please watch this video of what is going on with my notch :(


Warning: Music playing loud, if your speakers are turned up check ur volume.
http://vid1185.photobucket.com/albums/z355/AmericanEskimoKobe/Mobile%20Uploads/trimXDpECK_zpsbe39bf6c.mp4

10 seconds in i press the break and you see the steering wheel veer left
30 seconds in i go around a right corner and when i go back to straight the steering wheel is out of align.
35 seconds i sway out then in and it is straight again. 

My guess is there is two different issues.
1. Break issue  (breaking and steering wheel feels almost like a pop out of align when it goes left)

History on my breaks. Rear caliper was seized, put a new one on it, new breaks. Front did the breaks last month. Turned out my passenger front caliper there was a tear in the rubber on it and break fluid was leaking out. So we replaced with with a 88 front caliper.   

2. Power steering issue.

Not 100% on this. But my power steering rack leaks. A year ago i had to replace the pinon boot (ripped maybe there was a issue there that i didn't notice) This problem has been like this since April.  It has not gotten worse.
I don't know what else it can be.


Things done related to issue

Subframe bushing
breaks rotor
t/c kit
bearing checked from two mechanics.


Does anyone have a idea what might be causing this.

Facebook Share    

1987 200sx Notchback (originally from Georgia)

Offline G-E

  • Full Member
  • ***
  • Posts: 147
Re: Handling issues need help (Trouble shoot with me) :P
« Reply #1 on: 12:49:23 AM / 12-Sep-14 »
Video won't open for me, but have you checked the balljoints by trying to separate the arm and spindle with a crowbar? If they are good there should be no vertical movement

Take your tie-rod ends out of the steering knuckle and see if you can move the rack, see if the whole thing moves while someone holds the steering wheel straight

Offline guttersmash

  • Sub-n00b
  • *
  • Posts: 2
Re: Handling issues need help (Trouble shoot with me) :P
« Reply #2 on: 01:38:30 PM / 27-Nov-15 »
Any update on this? I am having the same issue.

Offline vern_k

  • Full Member
  • ***
  • Posts: 106
Re: Handling issues need help (Trouble shoot with me) :P
« Reply #3 on: 10:14:45 PM / 27-Nov-15 »
I would say rack bushings, could also be wheel bearings, and or ball joints. Jack her up with both front tires off the ground and see where the slack is 

Offline onephatser

  • n00b
  • **
  • Location: Topeka, KS
  • Posts: 71
  • 1986 S12/1996 B14 SE-R
Re: Handling issues need help (Trouble shoot with me) :P
« Reply #4 on: 03:41:00 AM / 01-Dec-15 »
The video isn't real great, but it kinda looks like after turning, your steering wheel will not return to center.  That is usually a problem with the valves internally in the rack.