Club-S12 International S12OC United Kingdom ClubS12 France S12Silvia Australia S12.org.ua Eastern Europe S12 of Sweden S12 Japan BBS
Please login or register.

Login with username, password and session length

Author Topic: What's missing?  (Read 1782 times)

Offline Daboman

  • n00b
  • **
  • Posts: 11
What's missing?
« on: 09:19:44 PM / 19-May-16 »
Basically the situation is that I bought somebody elses project, and it seems that there is a ton of things missing. My main two problems at the moment are my MAF sensor not doing anything at all, and my headlights aren't working on my passengers side. I was hoping somebody on here would be able to help me identify exactly what was taken out and whether or not that would be the cause of the problems I've been having. I know I'm still pretty new to this, so please be constructive.

First pic is in the same place as the wiper motor except on the other side of the engine bay.


This one is coming out of the same section of harness as the wiring for the headlights.

Facebook Share    


Offline weitrhino

  • Full Member
  • ***
  • Location: North Texas
  • Posts: 475
  • Vehicle: 1985 Nissan 200SX
  • '85 Notch just cracked 40k miles! RIP '86 Notch
    • Blue Mouth Promotions LLC
Re: What's missing?
« Reply #1 on: 11:07:48 PM / 19-May-16 »
I'm not sure what the plug is over the top of the brake booster. My car doesn't seem to have one as far as I can tell in the dark. Did yours have a cruise control?

The second pic is hard for me to tell just where you're looking. Perhaps a wider view indicating where this connector is would help.

Offline rednucleus

  • Old Fart #2
  • CONTRIBUTING MEMBER
  • Sr. Member
  • *****
  • Location: Marysville, WA
  • Posts: 2,038
  • Vehicle: 1985 Nissan 200SX
Re: What's missing?
« Reply #2 on: 11:12:34 PM / 19-May-16 »
1st pic the cruise control mounts just to the passenger side of the ground wire (see empty screw hole, mounts with three) & plug looks the same as the one to my cruise module. 2nd one, sorry, no help. Some wider view pics of entire engine bay might help.
What year car, motor, mods??
« Last Edit: 11:14:16 PM / 19-May-16 by rednucleus »

Offline kelso840

Re: What's missing?
« Reply #3 on: 07:41:01 AM / 20-May-16 »
Looks like the second pic is a tab connector coming off of the wiring group that's also got the lower ignition coil wires. That blue/white and black/white looks familiar.

Better pics on the second one will definitely be helpful.
Infrequently driving an s12.

Offline Daboman

  • n00b
  • **
  • Posts: 11
Re: What's missing?
« Reply #4 on: 12:23:26 PM / 21-May-16 »
It's an '87 Turbo with the stock ET, with basic turbo related additions.



Here's a better pic



The bay is a bit of a mess, that's the first thing I'm doing after I figure this out.
« Last Edit: 12:24:18 PM / 21-May-16 by Daboman »

Offline rednucleus

  • Old Fart #2
  • CONTRIBUTING MEMBER
  • Sr. Member
  • *****
  • Location: Marysville, WA
  • Posts: 2,038
  • Vehicle: 1985 Nissan 200SX
Re: What's missing?
« Reply #5 on: 01:07:50 PM / 21-May-16 »
Looking at that plug's condition, I'll bet it's one that was never in use in your car.  Harnesses are not custom to each car so we all have unused connectors all over the car depending on trim level & options ordered.

Offline Daboman

  • n00b
  • **
  • Posts: 11
Re: What's missing?
« Reply #6 on: 07:41:27 PM / 28-May-16 »
Here's a few more for you guys.












Offline kelso840

Re: What's missing?
« Reply #7 on: 12:47:15 PM / 29-May-16 »
That looks like a lot of the open plugs I've got on my car.

Never seen blue vacuum hoses before. Fancy fancy
Infrequently driving an s12.

Offline Daboman

  • n00b
  • **
  • Posts: 11
Re: What's missing?
« Reply #8 on: 04:29:29 PM / 01-Jun-16 »
But does anybody know what is supposed to plug in here? I would guess it maybe has something to do with the gauges but some solid information would go a long way. And what is the vaccum hose thats been plugged supposed to do?

Offline kelso840

Re: What's missing?
« Reply #9 on: 05:09:17 PM / 01-Jun-16 »
The thing that's been plugged on top of your intake is the pop up valve to release excess boost.

Looking at that photo made me realize your car is set up for a top mounted turbo..... Huh? Hope you've got a top mount turbo manifold we can all be jealous of.
Infrequently driving an s12.