Club-S12 International S12OC United Kingdom ClubS12 France S12Silvia Australia S12.org.ua Eastern Europe S12 of Sweden S12 Japan BBS
Please login or register.

Login with username, password and session length

Author Topic: CA18ET - harnesses help  (Read 394 times)

Offline Shadow989

  • n00b
  • **
  • Posts: 12
CA18ET - harnesses help
« on: 05:12:18 AM / 31-May-18 »
Hello! I have few questions about were which jack goes. When I bought car, there were few jacks that were disconnected and i don't know where to plug them because there is no other jack that I would plug into that disconnected jack, so i want to know are some components missing or they are just "blind end" jacks.

















Facebook Share    


Offline rednucleus

  • Old Fart #2
  • CONTRIBUTING MEMBER
  • Sr. Member
  • *****
  • Location: Marysville, WA
  • Posts: 2,026
  • Vehicle: 1985 Nissan 200SX
Re: CA18ET - harnesses help
« Reply #1 on: 03:57:40 PM / 31-May-18 »
the harnesses are installed with all possible options available, so you usually see a few spots with nothing to plug to.

Offline Shadow989

  • n00b
  • **
  • Posts: 12
Re: CA18ET - harnesses help
« Reply #2 on: 04:22:11 PM / 31-May-18 »
I have searched on internet today, and find out that 6 pin jack is for fuel pressure regulator module. Car didn't came with that module, but I saw some CA18ET with and without that module, therefore I don't know do I need that module od car will run without it?

As well, I saw in manual something called vacuum tank? In the engine bay there is some "holder" that looks like fire extinguisher holder, but there is nothing in it. So I assume that I'm missing some parts?

Offline JonB

  • CONTRIBUTING MEMBER
  • S12 Guru
  • *****
  • Location: SW Pennsylvania
  • Posts: 2,568
    • http://
Re: CA18ET - harnesses help
« Reply #3 on: 11:01:23 PM / 31-May-18 »
What year is this car?

I'm assuming you don't have it running?

I'm unaware of any vacuum tank, but I remember a vacuum pump on turbo models with cruise control.

There will be atleast one connector with nothing on it. I've had it on every S12 that I've owned. Nissan service diagnostic thing iirc.

Best bet is the service manual. Mention the year, and possibly get some help. The location, which you have, the number of pins, and the color of the wires helps. They're all identified in the FSM.

Offline Shadow989

  • n00b
  • **
  • Posts: 12
Re: CA18ET - harnesses help
« Reply #4 on: 09:04:31 AM / 01-Jun-18 »
It's 1985.

Offline JonB

  • CONTRIBUTING MEMBER
  • S12 Guru
  • *****
  • Location: SW Pennsylvania
  • Posts: 2,568
    • http://
Re: CA18ET - harnesses help
« Reply #5 on: 07:34:52 PM / 01-Jun-18 »
I have an 85 FSM here, but your going to need to tell me the colors of the wires for each connector you want. For me to go backwards and list all the possible connectors, with the wire colors in each area we may be looking at, so you can confirm is a good bit more time than I'm willing to invest.

The FSM does also show a vacuum tank as well as the vacuum pump.

You really should find an FSM and a multimeter for this because it's rarely going to be so easy as plug and go. For example; 38M for the intake coil is two connectors; one connector is two pins(black and white wire going directly to the fuse box-hot wire, and the other is a blue wire going to connector 32M where it connects to the engine harness in route to the ecu, on the engine harness side of the connector 32M, it should switch to blue with a white stripe wire where it connects to pin 5 of the ecu). The other single pin connector of 38M is a single blue wire, which travels to a resistor, connector 39M and exits light green where it goes to connector 32M then to the ecu PIN number 3 still light green.

In other words, pic four your holding two connectors, I think they're both 38M, the single blue one should go to the inline resistor, change to a light green wire, then to 32M, then to the ecu. The other connector, I can't see the wire color but I think it's also 38M which goes to the power transistor also should have two wires in there; one black and white, one blue.

And that ground one there should be 37M.

There was an FSM link once apon a time long ago, but I don't know where it's at anymore. And I have a multimeter with needles soldered to it to slip in pin connectors and wires, which also has a good 25' extension on one lead so I can check the harness in my cars. Invest in both of those things if you really want this car to go down the road - they're worth the cost.


Offline rednucleus

  • Old Fart #2
  • CONTRIBUTING MEMBER
  • Sr. Member
  • *****
  • Location: Marysville, WA
  • Posts: 2,026
  • Vehicle: 1985 Nissan 200SX

Offline BOSSMAN

  • Sr. Member
  • ****
  • Location: Vancouver BC CDN
  • Posts: 1,468
    • http://
Re: CA18ET - harnesses help
« Reply #7 on: 02:43:15 PM / 04-Jun-18 »
There was a discussion many years ago regarding some sort of fuel pressure relay that sets the pressure at maximum, it was from someone in Switzerland so it most likely for the European specs cars.  I think the purpose is to keep the pressure at maximum at maximum speed for your autobahn cruise? 
86 CA18ET....owner since 1990.
The name is Bossman, but you can call me Mr. Panda....My other car is a Buick....
My Skyline is here!  My Skyline is here!

Offline JonB

  • CONTRIBUTING MEMBER
  • S12 Guru
  • *****
  • Location: SW Pennsylvania
  • Posts: 2,568
    • http://
Re: CA18ET - harnesses help
« Reply #8 on: 06:49:53 AM / 06-Jun-18 »
I wouldnt know on models outside the US.

Iirc my 84 had a solenoid in the fuel pressure that kept it at full pressure for cold start where my 85 did not. That was on the ca20 models. Pretty sure my 85 turbo did not have that, but I could hunt im the manual if I find a minute

Offline BOSSMAN

  • Sr. Member
  • ****
  • Location: Vancouver BC CDN
  • Posts: 1,468
    • http://
Re: CA18ET - harnesses help
« Reply #9 on: 02:19:21 PM / 06-Jun-18 »
Yes, now that you mentioned it some models have the solenoid for either hot start or cold start condition but my 86 series 1 turbo didn't have it either.
86 CA18ET....owner since 1990.
The name is Bossman, but you can call me Mr. Panda....My other car is a Buick....
My Skyline is here!  My Skyline is here!

Offline CzechSilvia

Re: CA18ET - harnesses help
« Reply #10 on: 03:45:07 PM / 06-Jun-18 »
just rebuilt the whole fuel system in my 85 turbo and there aren't any solenoids there.
But what do I know? All I know about cars I learned from youtube...

Offline Shadow989

  • n00b
  • **
  • Posts: 12
Re: CA18ET - harnesses help
« Reply #11 on: 03:28:25 PM / 11-Jun-18 »
Car has started right up after 28 years and it is running great, but I have some error codes that came up. Codes are 21 and 22.

21 is for "ignition signal", and FSM says that I need to check continuity between pins 3, 5, 14 and ground (20 pin connector), so I went to check continuity with multimeter but there's no connection between pins and ground. Wire colors are light green with brown dots (pin 3), blue with white strip (pin 5) and blue with red strip (pin 14). If I have understood correctly, those wires should be connected to ground?

Code 22 is for fuel pump. FSM says that when key is switched to "ON" position, fuel pump should run for about 5 seconds? When I switch key to "ON" position, fuel pump runs constantly, so I guess thats not normal? In FSM stands that on pin 108 at 15 pin connector should be about 12v(battery voltage), but I have measured 3v. Any solutions for this problem?

Besides of that error codes, engine is running normally.


Offline Shadow989

  • n00b
  • **
  • Posts: 12
Re: CA18ET - harnesses help
« Reply #12 on: 05:28:31 PM / 14-Jun-18 »
Someone please help?

Offline JonB

  • CONTRIBUTING MEMBER
  • S12 Guru
  • *****
  • Location: SW Pennsylvania
  • Posts: 2,568
    • http://
Re: CA18ET - harnesses help
« Reply #13 on: 08:43:09 PM / 14-Jun-18 »
Oh, sorry.

I think on the 21, the wires go to a diode pack, then to ps, blower motor, and something else. I could put a little more research there, but I think its all good. Basically just tweaking the the timing on engine load at idle Im assuming.

On the 22, id have to grab the fsm for sure. 3v certainly doesnt sound right does it. Ill try to get some free time to read through the circuit in the fsm this weekend. What comes to mind is ohms law, and checking resistance component by component to see whats dropping the voltage, but i havent read any of the diagnostic on the pump in the fsm.

Offline Shadow989

  • n00b
  • **
  • Posts: 12
Re: CA18ET - harnesses help
« Reply #14 on: 11:11:31 AM / 23-Jun-18 »
I have fixed ecu connector, and now car is running smooth at idle, and when I drive it normally it drives great, but if I press throttle pedal "hard" car starts to run rough(we have expression in Croatia that describes how it runs but i don't know how to translate it).  Any ideas why? Car doesn't have exhaust yet(only manifold with lambda sensor), but i don't think thats a problem?
« Last Edit: 11:13:49 AM / 23-Jun-18 by Shadow989 »

Offline CzechSilvia

Re: CA18ET - harnesses help
« Reply #15 on: 03:53:52 PM / 23-Jun-18 »
Could be a dirty MAF sensor or perhaps some issue resulting in weak spark like bad spark plugs or worn ignition coils...
But what do I know? All I know about cars I learned from youtube...

Offline weitrhino

  • Full Member
  • ***
  • Location: North Texas
  • Posts: 454
  • Vehicle: 1985 Nissan 200SX
  • '85 Notch just cracked 40k miles! RIP '86 Notch
    • Blue Mouth Promotions LLC
Re: CA18ET - harnesses help
« Reply #16 on: 03:56:11 PM / 23-Jun-18 »
If the car sat for as long as you say then I'd be looking at the fuel delivery system in general. Start with the fuel filter then make sure the fuel pressure regulator is functioning properly. Now that you've pressed on the gas pedal it might be worth seeing if the ECU has new codes.

Also, I'd go over all the vacuum lines to be sure they're in the proper places and the old rubber hoses aren't deteriorating.

Offline Shadow989

  • n00b
  • **
  • Posts: 12
Re: CA18ET - harnesses help
« Reply #17 on: 06:41:13 AM / 24-Jun-18 »
Engine is completly rebuilt, all new hoses, spark plug wires, spark plugs, rotor and distributor cap, ultrasonic cleaned fuel injectors, all new filters, cleaned gas tank and fuel pump... Everything is new.

How can I clean MAF sensor?

I will check for the codes on ECU

Offline CzechSilvia

Re: CA18ET - harnesses help
« Reply #18 on: 01:47:43 PM / 24-Jun-18 »
Easy, just unscrew a bolt or two that holds the sensor in its aluminium housing which is located just behind the air filter box, carefully pull the sensor out of the housing and spray the shit out of it with a spraycan of MAF sensor cleaner or carb cleaner, it's probably the same stuff anyway and they just brand it differently.

It worked wonders for me, I had a problem where I could rev the engine alright when the throttle was opened just a little bit but when the throttle opened more than half way the engine started to choke and the rpm dropped. Cleaning the MAF sensor fixed it for me, it's worth a try, the MAF cleaner can is cheap stuff
But what do I know? All I know about cars I learned from youtube...

Offline Shadow989

  • n00b
  • **
  • Posts: 12
Re: CA18ET - harnesses help
« Reply #19 on: 01:56:53 PM / 05-Jul-18 »
I have cleaned MAF but no changes, it starts normally hot or cold, has good idle, but won't accept more than 1/4 of throttle when driving, but I can rev it in neutral normally.

I have noticed that while driving, if I press throttle fully open it starts choking and but when it goes above 5200rpms it starts to accelerate normally.

I forgot to say that I have blocked EGR valve with full gasket(gasket with no hole), could that be a problem?

Could low fuel pressure be a problem? But I guess that then it wouldn't accelerate normally above 5200 rpms?

Could bad lambda sensor be a problem?