Club-S12 International S12OC United Kingdom ClubS12 France S12Silvia Australia S12.org.ua Eastern Europe S12 of Sweden S12 Japan BBS
Please login or register.

Login with username, password and session length

Author Topic: Fuel Pressure Regulator  (Read 105 times)

Offline deucekazoo

  • Full Member
  • ***
  • Location: Central IL
  • Posts: 128
Fuel Pressure Regulator
« on: 08:19:47 AM / 21-Jun-19 »
Started having an issue with the car so I thought I would ask you guys what to check. I think it might be the pressure regulator but what to see what you guys thought.
So the car died on me the other day after I replaced the alternator. I think this was a fluke but looked to make sure I did not disconnect anything when replacing the alternator. I checked everything and could not see an issue. The car started a few hours later without and issue. I ran it all week and then it did the same thing yesterday. I limped it home and it does not idle right. At idle it goes lean until I rev it. I replaced the fuel filter and still same thing. I have a gauge on the fuel line and read somewhere where these guys should run 30 psi at idle which it did but now it shows 60 psi and goes up at idle. After the new fuel filter it showed 30 psi so took it for a spin. Not a good idea. I had to be in first to get up my hill home. Any higher gear and it had no power at all and started to buck. So is my assumption correct about the FPR? What do you guys think?
Thanks for any help.
John

Facebook Share    


Offline JonB

  • CONTRIBUTING MEMBER
  • S12 Guru
  • *****
  • Location: SW Pennsylvania
  • Posts: 2,599
    • http://
Re: Fuel Pressure Regulator
« Reply #1 on: 01:39:06 PM / 21-Jun-19 »
Thats a tough one.

Id suspect vac lines. Both the fpr, because I thing its output pressure is related to the vacuum. And then the charcoal canister, as it sports the purge, which im not saying it is, but the accel, and hills, ect, makes me think its not purging, and it starves for fuel cause fuel slosh in the tank.

I could be completely wrong though

Offline deucekazoo

  • Full Member
  • ***
  • Location: Central IL
  • Posts: 128
Re: Fuel Pressure Regulator
« Reply #2 on: 04:09:43 PM / 21-Jun-19 »
It's something to check, the purge canister. I also thought vacuum lines but I looked and did not see anything unplugged. I also replaced all the vacuum lines with new silicone lines when I bought the car. All the original rubber lines were dry rotted.
One other thing I need to check is the solenoid that controls the vacuum before it gets to the FPR. This is supposed to be for warm starts.
The thing is the car should run at 37 psi when the throttle is fully depressed and at 30 psi at idle. It should not be seeing 60+ psi and that is why I think the FPR is bad.
I went ahead and ordered a new adjustable FPR. I will have to cut the old one off and get AN fittings to connect everything. I hope this fixes the issue. I will let you guys know.
Thanks,
John

Offline deucekazoo

  • Full Member
  • ***
  • Location: Central IL
  • Posts: 128
Re: Fuel Pressure Regulator
« Reply #3 on: 09:32:29 AM / 02-Jul-19 »
Finally got it fixed. It was the fuel pressure regulator.
I removed the fuel rail and cut the old pressure regulator off. I then connected the two open fuel rail tubes with high pressure fuel line. I put everything back together. I then added the new pressure regulator to the RH shock tower. I used the bracket that came with the regulator, just bend and twisted it to fit my application. The pressure regulator I bought was the Aeromotive 13301. This one is nice because it is universal and set up for both carb and low pressure fuel injected cars. It comes with two springs, the first goes from 3-20 psi and the second spring is from 20-65 psi. I used the second spring. Our cars idle at 30 psi and are full throttle at 37 psi, which is kind of in the middle of the range. One of the harder parts was trying to figure out how to run the pump full on so I can set the pressure. I have a service manual and looked up the wiring for it. Then found out the manual I have is for mid year 1986 cars. Mine is a 02-86 so I also had the PDF of the service manual that is for my car. Both of them are quite different on how the fuel system wiring is. The early cars don't have a relay on the fuel pump, the later cars do but both of them did not have the wire colors I was seeing on my harness. That shit drives me nuts, looking at a schematic where no wire colors match. But finally found the two wires I needed to activate the fuel pump. Set it at 37.5 psi and all is good to go, well after finding I forgot to connect one of the vacuum lines. Its nice having gauges on the car, they help trouble shoot. The car runs great again.